Errata
Held for Document Update (2)
RFC 4335
Source of RFC: secsh (sec)
Errata-ID: 1309
- Status:
- Held for Document Update
- Type:
- Technical
- Reported By:
- Alfred Hoenes
- Date Reported:
- 2008-02-05
- Held for Document Update by:
- Pasi Eronen
Section 3, 1st para says:
The following channel-specific request can be sent over a session
channel (as described in [4]) to request that the remote host perform
a BREAK operation.
It should say:
The following channel-specific request can be sent over a session
| channel (as described in [5]) to request that the remote host perform
a BREAK operation.
Notes:
The relevant information is in RFC 4254 [5], "SSH Connection Protocol",
in particular sections 5 and 6.
RFC 4253 [4] does not even mention the concept of session channels
to any notable detail.
Errata-ID: 1310
- Status:
- Held for Document Update
- Type:
- Editorial
- Reported By:
- Alfred Hoenes
- Date Reported:
- 2008-02-05
- Held for Document Update by:
- Pasi Eronen
Section 3, last para says:
If the 'want_reply' boolean is set, the server MUST reply using an
SSH_MSG_CHANNEL_SUCCESS or SSH_MSG_CHANNEL_FAILURE [5] message. If a
BREAK of any kind was preformed, SSH_MSG_CHANNEL_SUCCESS MUST be
sent. If no BREAK was preformed, SSH_MSG_CHANNEL_FAILURE MUST be
sent.
It should say:
If the 'want_reply' boolean is set, the server MUST reply using an
SSH_MSG_CHANNEL_SUCCESS or SSH_MSG_CHANNEL_FAILURE [5] message. If a
| BREAK of any kind was performed, SSH_MSG_CHANNEL_SUCCESS MUST be
| sent. If no BREAK was performed, SSH_MSG_CHANNEL_FAILURE MUST be
sent.
Notes:
s/preformed/performed/g