Errata
Held for Document Update (1)
RFC 2825
Source of RFC: IAB
Errata-ID: 3124
- Status:
- Held for Document Update
- Type:
- Editorial
- Reported By:
- Gabriel Montenegro
- Date Reported:
- 2012-02-16
- Held for Document Update by:
- IAB-Chair
Section 3.3 says:
Also, the Simple Network Management Protocol (SNMP) uses the textual
representation defined in [RFC2579]. While that specification does
allow for UTF-8-based domain names, an informal survey of deployed
implementations of software libraries being used to build SNMP-
compliant software uncovered the fact that few (if any) implement it.
It should say:
Also, the Simple Network Management Protocol (SNMP) uses the textual
representation defined in [RFC2579]. That specification does not
allow for UTF-8-based domain names, and an informal survey of deployed
implementations of software libraries being used to build SNMP-
compliant software confirmed the fact that few (if any) implement
it.
Notes:
RFC2579 is pretty clear about ASCII-only here. Whereas using SnmpAdminString in RFC2571 could allow for UTF-8 in the interest of i18n, that is not what is being discussed here.