Errata

Verified (2)

RFC 10042 inline-errata

Source of RFC: sshm (sec)

Errata-ID: 9159

Status:
Verified
Type:
Technical
Publication Format:
TXT
Reported By:
Nikolai Malykh
Date Reported:
2026-09-01
Verified by:
Deb Cooley
Date Verified:
2026-10-12

Section 2.1 says:

If any of these checks fail, the client
MUST abort using a disconnect message (SSH_MSG_DISCONNECT) with a
SSH_DISCONNECT_KEY_EXCHANGE_FAILED as the reason.

It should say:

If any of these checks fail, the server
MUST abort using a disconnect message (SSH_MSG_DISCONNECT) with a
SSH_DISCONNECT_KEY_EXCHANGE_FAILED as the reason.

Notes:

The client has no information about the results of the server-side check.

RFC EDITOR: Edited Original/Corrected text to only include sentence that is affected.

Errata-ID: 9160

Status:
Verified
Type:
Editorial
Publication Format:
TXT
Reported By:
Nikolai Malykh
Date Reported:
2026-09-01
Verified by:
Madison Church
Date Verified:
2026-09-02

Section 5 says:

The security considerations given in [RFC5656] and [RFC8731] also
   apply to the ECDH part of the P/T Hybrid key exchange schemes defined
   in this document.

It should say:

The security considerations given in [RFC5656] and [RFC8731] also
   apply to the ECDH part of the PQ/T Hybrid key exchange schemes defined
   in this document.

Notes:

Typo
Report New Erratum