Browse free open source Python Libraries and projects below. Use the toggles on the left to filter open source Python Libraries by OS, license, language, programming language, and project status.

  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • Veeam Data Platform v13.1 - Get Your Free Trial Icon
    Veeam Data Platform v13.1 - Get Your Free Trial

    Secure by design, portable by default. Recover clean, fast, anywhere. Start a free trial.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try it Free
  • 1
    gditools

    gditools

    A Python program/library aimed at GD-ROM image files.

    This Python program/library is designed to handle GD-ROM image (GDI) files. It can be used to list files, extract data, generate sorttxt file, extract bootstrap (IP.BIN) file and more. This project can be used in standalone mode, in interactive mode or as a library in another Python program (check the 'addons' folder to learn how). For your convenience, you can use the gditools.py GUI program supplied in the Files section (optional). To use this project you must install the Python 2.7.x branch release binaries. See the README.TXT file for more informations.
    Leader badge
    Downloads: 11 This Week
    Last Update:
    See Project
  • 2
    Assorted projects. General-purpose libraries for Python, C++, Scala, bash, and others. Meta-programming tools. System utilities. UI components. Web APIs. Configuration files. Benchmarks. Programming competition entries. And much more.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 3
    PyMW is a Python module for parallel master-worker computing in a variety of environments. With the PyMW module, users can write a single program that scales from multicore machines to global computing platforms.
    Downloads: 0 This Week
    Last Update:
    See Project
  • 4

    pyhard2, control hardware from python

    An object-oriented framework for the development of instrument drivers

    pyhard2 is an object-oriented framework to help in the development of instrument drivers. pyhard2 is proposed as an alternative to LabVIEW. Emphasis is given on serial drivers but the framework can be used with any socket. The source also contains the implementation of a PID controller and a setpoint ramp generator. The instrument drivers may further be incorporated in a GUI, using, e.g. PyQt or PySide. Threading is automatically taken care of. Furthermore, generic GUI (called controllers) are provided and can be extended.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Fully Managed MySQL, PostgreSQL, and SQL Server Icon
    Fully Managed MySQL, PostgreSQL, and SQL Server

    Automatic backups, patching, replication, and failover. Focus on your app, not your database.

    Cloud SQL handles your database ops end to end, so you can focus on your app.
    Start Free
  • 5

    vsResolver

    DNS Validating Stub Resolver

    The Validating Stub Resolver (vsResolver) is a DNS stub resolver that implements the Domain Name System Security Extensions (DNSSEC) specified in RFC 4033, RFC 4034 and RFC 4035. These add data origin authentication and data integrity to the Domain Name System. vsResolver extends the dnspython toolkit (http://www.dnspython.org/) and uses the pycrypto library for its underlying crypto implementation(https://www.dlitz.net/software/pycrypto/). Click on this link for a ridiculously simple python page demonstrating vsResolver working - http://superawesum.novas.us/py/hello.py. Try entering some domains and click submit. Then, enable details, click submit to get the details,and compare with what you get for that domain at http://dnssec-debugger.verisignlabs.com.
    Downloads: 0 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • Next